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In this worksheet, we will solve two physical problems using a numerical toolbox called
COMSOL Multiphysics (FEMLAB). In the first part, we calculate the heat conduction in
a simple heat sink (aluminium) cooling a high voltage copper cable. In the second part,
we simulate the fluid flow around a cylinder.
Save both scenarios in model files, answer all the questions, and fill the tables for the
personal presentation.
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Copper Cable in a Simple Heat Sink (2D)
Aluminium Heat Sink

273 K

1e9 W/m^3

Copper Cable
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a) Build the heat sink geometry.
1. Start COMSOL, go to the New page in the Model Navigator.
2. Select Space dimension: 2D.
3. Expand COMSOL Multiphysics, expand Heat Transfer, expand Conduction,
select Steady-state analysis, and press OK.
4. Press Draw Mode icon if this is not pressed by default.
5. Hold SHIFT and press Rectangle/Square icon in the Draw tool bar (left).
Draw a rectangle with the parameters Width = 0.09, Hight = 0.03, Position x
= 0.0, and Position y= 0.03.
6. Hold SHIFT and press Rectangle/Square icon. Draw a rectangle with the
parameters Width = 0.03, Hight = 0.09, Position x = 0.03, and Position y= 0.0.
7. Select all objects in the work space by pressing CTRL-A. Press Zoom Extents
icon. Click on Create Composite Object icon and press the Union button
in the Shortcut frame of the opening dialog box. Note that R1 + R2 appears
in the Set formula field. Uncheck the Keep internal borders check box and
press OK to create the composite solid object.
8. Copy the composite solid object by pressing the Copy icon in the icon bar.
Press the Paste icon to open the Paste dialog box. Enter 0 in the field for
both the X-displacement and the Y-displacement and press OK.
9. Press the Rotate icon and enter a Rotation of 45 degrees in the opening
dialog box. Enter 0.045 in both the field for Center point x and Center point
y and press OK.
10. Select all objects in the work space by pressing CTRL-A and press the Intersection icon.
11. Hold SHIFT and press Ellipse/Circle (Centered) icon. Enter 0.015 in the
field for Radius and 0.045 for the x and y coordinate of the Center.
b) Set boundary conditions and material parameters.
1. Open the Physics menu in the menu bar. Select Boundary Settings to
specify the boundary conditions. Go to the Boundaries page in the left
frame. Hold SHIFT and mark all outer boundaries with the mouse. Switch to
the Boundary Condition page in the right frame and select Temperature
in the Boundary condition selection box. Enter 273 in the edit field for T0 and
press OK.
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2. Open the Physics menu in the menu bar. Select Subdomain Settings to
specify the material parameters. Mark the round inner subdomain in the left
frame. Switch to the Physics page in the right frame and load the Library
material Copper. Enter 1e9 for the Heat source Q. Mark the outer subdomain
in the left frame. Switch to the Physics page in the right frame and load
the Library material Aluminium. Enter 0 for the Heat source Q because their
is no heat source in the cooling element. Press OK to close the dialog box.
3. Save now your “raw” COMSOL model. So that you can start from this state
later on! Don’t overwrite this file!
c) Solve the Problem and visualise the result.
1. Select all objects in the workspace. Open the Mesh menu in the menu bar.
Select Free Mesh Parameters to open the corresponding dialog box. Select
Normal in the Predefined mesh sizes selection box and press Remesh. Press
OK to close the dialog box.
2. Press the Solve icon. After solving the problem you will get a surface plot
of the distribution of temperature in the domain.
3. Open the Postprocessing menu in the menu bar. Select Plot Parameters
to open the corresponding dialog box. Open the page General. Uncheck auto
and set the value of the element refinement to 1. Open the page Surface and
select Flat in the Coloring selection box and press Apply. Plot the Temperature
gradient instead of the Temperature.
4. What is your observation?
short answer

5. Open the page Streamline in the Plot Parameters dialog box. Activate
the Streamline plot by checking the box at the top of the page. Select Heat
flux in the Predefined quantities selection box, select Magnitude controlled in
the Streamline plot type selection box, use 30 start points and press Apply.
6. Export your plot to an eps-file! Open file in the menu bar. Select Export
and Image. Use the Preview to see if the plot looks fine. Enlarge the plot, if
its components look as they were pressed together.
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7. Open the Mesh menu in the menu bar. Select Mesh Statistics to get more
information about the mesh. Write the number of elements into the table
below.
8. Open the Postprocessing menu in the menu bar. Select Boundary Integration to open the corresponding dialog box. Select all outer boundaries!
Select Normal heat flux in the Predefined quantities selection box and press
Apply to integrate the heat flux over the outer boundary. Read the value
from the logging screen and write it into the table below.
9. Refine the mesh and calculate a new solution. Integrate once more the flux
over the outer boundary and write the result together with the number of
elements into the table below. Round the values to the third significant digit.
Refine the the mesh and calculate the flux over the outer boundary until the
rounded third significant digit does not change anymore. Write your results
down in the table! Change the linear system solver to Geometric multigrid
(Solve →Solver Parameters) if you run into memory problems.
# elements
value of the integral
# elements
value of the integral
d) Solve the Problem with hand-made mesh refinement.
1. Open your “raw” model! Open the Mesh menu in the menu bar. Select Free
Mesh Parameters to open the corresponding dialog box. Open the page
Boundary! Mark all outer edges! Open the sub-page Distribution and
check Constraint edge element distribution. Set the number of edge elements
to 12. Mark the Distribution check box. Set element ratio to 5 and select
Exponential for the Distribution method.
Take care that you refine the mesh in the neighbourhood of the “inner corners”. So, check the direction of the exponential distribution along the outer
edges and reverse the direction if necessary!
2. Save this COMSOL model to a new file!
3. Calculate a new solution. Integrate the flux over the outer boundary and
write the result together with the number of elements into the table below.
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Round the values to the third significant digit. Refine the the mesh and calculate the flux over the outer boundary until the rounded third significant digit
does not change anymore. Write your results down in the table! Change the
linear system solver to Geometric multigrid (Solve →Solver Parameters)
if you run into memory problems.
# elements
value of the integral
# elements
value of the integral
e) Solve the Problem with an adaptive mesh refinement.
1. Open your “raw” model! Press the Initialize mesh icon.
2. Open the Solve menu in the menu bar. Select Solver Parameters to open
the corresponding dialog box. Activate Adaptive mesh refinement and press
OK.
3. Calculate a new solution. Open the Postprocessing menu in the menu bar.
Select Plot Parameters to open the corresponding dialog box. Open the
page General. Uncheck auto and set the value of the element refinement to
1. Open the page Surface and select Wireframe in the Fill style selection box
and press Apply. What is your observation?
short answer

4. Integrate the flux over the outer boundary and write the result together with
the number of elements into the table below.
5. Open the page Adaptive in the dialog box Solver Parameters. Set the
value for Maximum number of refinements to 3. Initialise the mesh! Calculate a
new solution. Integrate the flux over the outer boundary and write the result
together with the number of elements into the table below. Round the values
to the third significant digit. Increment the number of mesh refinement steps
for the adaptive solver and calculate the flux over the outer boundary until the
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rounded third significant digit does not change anymore. Initialise the mesh
before each calculation! Write your results down in the table! Change the
linear system solver to Geometric multigrid (Solve →Solver Parameters)
if you run into memory problems.
# elements
value of the integral
# elements
value of the integral
6. Compare your results with the ones from the parts c) and d)!
7. Save your COMSOL model.
f ) Solve the Problem with an adaptive mesh refinement and “round” corners.
1. Open your “raw” model and switch to the Draw mode.
2. Press the Fillet/Chamfer icon in the draw tool bar. Mark all “inner corners”. Select Fillet, set the radius to 0.0005 and press OK.
3. Initialise the mesh! Calculate a new solution, using an adaptive solver. Integrate the flux over the outer boundary and write the result together with the
number of elements into the table below. Round the values to the third significant digit. Increment the number of mesh refinement steps for the adaptive
solver and calculate the flux over the outer boundary until the rounded third
significant digit does not change anymore. Initialise the mesh before each
calculation! Write your results down in the table! Change the linear system
solver to Geometric multigrid (Solve →Solver Parameters) if you run into
memory problems.
# elements
value of the integral
# elements
value of the integral
• Compare your results with the ones from the parts c), d) and e)!
• Save your COMSOL model.
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Flow around a cylinder (2D)
inlet

U=V=0
outlet

0.41m

2

0.15m

0.1m
0.15m

U=V=0

2.2m
a) Setup and simulate a stationary flow scenario
1. Start COMSOL and initialise an Incompressible Navier-Stokes model in 2D
(COMSOL Multiphysics → Fluid Dynamics) in the Model Navigator.
2. Build a flow channel using the geometry information given in the figure above.
3. All external forces are neglected. The fluid is specified by its density ρ =
1.0kg/m3 and its dynamic viscosity η = 10−3 P as.
4. Define a new constant (Options→Constants) Umax and assign the value
0.3 to this constant.
5. Specify an inflow boundary condition at the short edge (of the flow channel)
near to the cylinder. Use the expression 4 ∗ U max ∗ y ∗ (0.41 − y)/(0.41 ∗ 0.41)
to give the velocity in x-direction at the inflow boundary. Set the velocity
in y-direction at the inflow boundary to zero. Specify an outflow boundary
condition at the opposite edge and no-slip boundary conditions at all other
edges of the channel including the surface of the cylinder.
6. Choose a Stationary nonlinear solver with Adaptive mesh refinement. Use the
GMRES solver with the Incomplete LU preconditioner to simulate this stationary flow scenario. Start with a fine mesh and force the solver to perform
three adaptive refinement steps.
b) Visualise a stationary flow scenario
1. Plot the mesh in the neighbourhood of the cylinder and save the plot in a
file.
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2. Plot the Velocity field in a Surface plot, add a Streamline plot based on the
Velocity field as well. Specify the start point coordinates of the streamlines by
the x-coordinates 0.25, 0.25, 0.0, 0.0, 0.0, 0.0 and the y-coordinates
0.19, 0.23, 0.19, 0.22, 0.15, 0.25.
3. Determine the pressure up-stream and down-stream of the cylinder
(Postprocessing → Point Evaluation). Hint: the pressure is accessible
by the expression p.
pressure up − stream

pressure down − stream

4. Determine both components of the force acting on the surface of the cylinder
by calculating the integral of the predefined quantity Total force per area over
the boundary of the cylinder (Postprocessing → Boundary Integration).
f orce in x − direction

f orce in y − direction

5. Save your COMSOL model.
c) Simulate a time dependent flow scenario
1. Change the constant Umax to 3.0 in oder to specify a time dependent flow
problem.
2. Change consequently the solver properties to Time dependent. Simulate 5
seconds with an output time step of 0.05 (Solver parameters → General →
Time stepping → Time). Try to use a direct solver.
3. Use the adaptively refined mesh from the stationary solution.
4. Create an animation of the flow field of the time dependent solution
(Postprocessing → Plot Parameters → Animation).
5. Create a new variable Fy (Options → Integration Coupling Variables →
Boundary Variables) using the expression T y ns and all parts of boundary
of the cylinder. Click on Update Model in the Solve menu in order to
calculate the values for the new defined variable.
6. Plot the variable Fy over the simulation time and estimate the frequency
of the oscillating flow (Postprocessing → Domain Plot Parameters →
Point).
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f requency

7. Save your COMSOL model.
d) Simulate a time dependent flow scenario with additional heat transfer
1. Start your model from the previous part. Open the Model Navigator in
the Multiphysics menu. Add the Convection and Conduction Heat Transfer
mode in addition to the existing Navier-Stokes mode.
2. Take care that the Convection and Conduction mode is active in the Multiphysics menu and open the Subdomain Settings. Set the thermal properties of the fluid: The density ρ, the conductivity k = 40W/(mK), and the
heat capacity Cp = 800J/(kgK). Initialise the fluid with a temperature of
273K.
3. Couple the velocity field in the heat equation with the velocity field in the
Navier-Stokes (NS) equation. Hint: The expressions for the two components
of the velocity in the NS mode are u and v.
4. Open the Boundary Settings dialog box. Set the temperature at the inlet,
the southern, and the northern boundary to 273K. Set the temperature at
the boundary of the cylinder to 323K. Assume that the diffusive flux normal
to the outlet boundary is zero.
5. Simulate 5 second with an output time step of 0.05. Start with the last solution of the previous part, by modifying the initial values of the flow domain,
using the expressions for primary variables of the flow domain. Change the
initial behaviour of the solver (Solve → Solver Manager → Initial value
→ Initial value expression evaluated using current solution).
6. Check the initialisation with Solve → Get initial value. Start the simulation, if everything works.
7. Plot the distribution of the temperature and save the plot to a file.
8. Create an animation of the temperature field.
9. Save your COMSOL model.
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